Friday, December 10, 2010

Installing Adobe Reader X on Windows 7 - problem with Microsoft Windows Search Filter Host

As you may know, there is new Adobe Reader X which bring important security improvements in this bug infested application.
So I wanted to install it on my Windows 7 Professional. All went well until the following error:

Files in use: Microsoft Windows Search Filter Host


Now, what do you think that a normal user would do? Nothing at all! There is no way to close this process as it is not an Windowed application, nor running in a system tray.
So what is it then? Quick search on Google shows that the process name is SearchFilterHost.exe.


And it is running as SYSTEM. As I am administrator on this host I can try "End process". So I did, but the process simply restarts! 

Conclusion: I cannot install Adobe Reader X on my WIndows 7 in normal mode.

11 comments:

  1. you just need to be quick with the killing of the process and clicking retry. Worked for me.

    ReplyDelete
  2. It's risky but if you're very quick you can end the process and start it installing again, this seems to stop the process from starting again until installation is complete

    ReplyDelete
  3. I had this issue and resolved it by closing MS Outlook.

    ReplyDelete
  4. Run services.msc and stop the service. it will restart when windows restarts

    ReplyDelete
  5. I am running Windows Vista. Trying to install Adobe Reader X returned the same message as above. But I resolved it by running services and stopping Windows Search.

    ReplyDelete
  6. John Larger , thank you very much, I opened services.msc and stopped the service called: windows Search, I then successfully uninstalled Adobe reader X.

    I am now going to attempt a fresh reinstall of Adobe reader X.

    ReplyDelete
  7. Stop this service in services.msc

    "ActivIdentity Shared Store Service"

    then perform uninstall.

    ReplyDelete
  8. Restart Windows, browse to adobe.com from *Chrome* browser, download and install, don't open any other windows or applications. Worked for me on Windows 7.

    ReplyDelete
  9. Thanks for this blog post. I had the same exact problem. I did the combo of closing Outlook and End Process of host application in Task Manager and then retry of the process. It worked!

    ReplyDelete